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CONTENTSCONTENTS

HOVIS Lite, Eco DR SIM
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  System requirement

  Minimum Intel Pentium 800 Mhz

  Windows XP, Windows Vista, Windows 7

  Minimum 256 MB RAM

  Hard Disk Space 300 MB required

  USB Port

  Macintosh(under development)

Installation01
DR-SIM Introduction

DR-SIM, also called ‘motion editor’ is an easy to use robot motion editing software 

tool. In addition to motion creation, editing, and capturing actual robot motion, 

DR-SIM supports powerful simulation function that allows the user to simulate the 

motion prior to applying it to the robot. DR-SIM also incorporates timeline feature 

similar to the ones found in video editing software.

Timeline allows the user to create motion based on time and to add multimedia 

effect to the motion by adding LED lighting effect and sound in the timeline.
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Follow Instructions / From installation to running the program

01 Installation File

Click on installation file.

02 Start installation wizard

Click “Next” button.

Click

Click

03 Select installation folder

Click “Next” button.
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04 Confirm installation

Click “Next” button.

05 Start installation

Starting installation. 

Wait untill the installation bar ends.

Click

06 Confirm installation

Click “Close” button

Software installation complete.

07 Check executable file

Check for the executable file, desktop 

shortcut icon and from Windows Start > 

All Programs > Dongbu Robot > DR-SIM.

Click on the executable file to run the 

program.

If the porgram did not install properly, 

install the Microsoft, Net Frame work 3.5 

and try again.

Click
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Hello 
DR-SIM 02
First example of creating motion. Use DR-SIM tor create simple motion and run 

the motion simulation.

Connect to the robot and download the created motion file and then check the 

motion being applied by the robot.

00 Run program

Click on DR-SIM icon and run the

program.

01 Full Screen

DR-SIM Full Screen.

Timeline is in the middle and motion 

editior at botom. 

Motion is usually created or edited using

the timeline and 3D motion window.

02 Basic Posture

Insert the basic posture in the robot 

motion starting point or in the first frame.

Place the posture in the 3D motion 

window as basic posture Click first frame 

Insert the key frame at the top. Click on 

(Key icon)

Basic posture has been inserted in the 

key frame.

If the posture in the 3D motion window 

is not a basic posture, select it as basic 

posture from the tool bar on the right.

(Shortcut Alt + I)

Click1

Click2
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05 Insert Edited Motion

Insert the motion edited in 3D window 

into desired timeframe. After inserting the 

motion, click on the “    ”at the top to 

view the simulation in the 3D window.

03 3D Window

To enlarge the 3D window, Menu > View 

> Click on ‘New 3D Window’.

Click and drag to enlarge the new 3D 

window.

04 Motion Edit

Click on the robot joint and thin yellow 

joint movement line will appear. 

Click and hold left mouse button on 

the line and drag.

Lift the left hand up left and the right 

hand up front.

Click2

Click

Click

Click1
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Click

Click1 Click3Click2

06 Inserted Frame Midpoint Check

To view the motion between two frames, 

click on the timeframe section between 

the basic motion and the edited motion.

07 Connecting to Robot

Use the USB to Serial converter cable to 

connect the robot to the USB port of PC 

or notebook computer. Click “Connect” 

icon to make the connection. Check the 

Com port if the connection does not 

occur. Click “Torque On” button and try 

moving the robot arm or the leg by hand.

Torque is on if the robot does not move. 

Click on “Robot Play” button and robot 

will move following the created motion,

This ends the first lesson on creating 

robot motion and play.

08 Reference : COM Port Setting

If the connection to the robot does not 

occur, it is most likely due to wrong 

Com port settings.

Right click on “My Computer”, click on 

“Properties” to open “System Properties” 

window, click on “Hardware” tab to 

open the device manager.

Click Com port to view the list of 

configurable Com ports. Select COM2 

connected to the USB and save. Com 

port connected to the robot should now 

be open.
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09 Reference : COM Port Setting

Select COM2 and save.

Robot and PC software should now 

connect.

Click1

Click2
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User 
Interface 03

0

1

2

3

4

5

6

7

8

Instructions Connect Robot

Short Cut

Mini Timeline

Timeline

Face LED Sound

3D Motion
Window

Motor Setup
Window

Instructions : DR-SIM detailed user instructions. Press F1 to view Help .

Short Cut : Collection of frequently used menus. Simulation Play, Insert Keyframe, and etc.

Mini Timeline : Shows the outline of whole timeframe.

Timeline : Created or edited motion can be placed by time.

3D Motion Window : Edit robot motion or view the motion simulation.

Face LED : Enables user to edit Face LED. Insert into timeframe after editing.

Sound : Select saved sound. Insert into timeframe after selcection.

Motor Setup Window : Configure values and LED settings by ID for all motors used in the robot.

Connect Robot : Shortcut for connecting to the robot. Used to download motion file to the  robot or to 
                              capture actual robot motion.
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Help04
Click ‘Help’ on the menu bar to popup the help window. We recommend reading 

the Help files prior to using the DR-SIMprogram. ( Click ‘Help’ > Click’Index’ > Click 

‘Timeline’ on left menu  Window shown below will open up  

Com Setting : Instruction on setting up the COM port.

Main Window Major Functions :  Instructions on how to use program functions. 

Menu Bar
Quick Menu
Robot Control Setting
Timeline
3D Motion Window
Face LED
Servo Motor Values
Environment Setting

Tutorial

Creating Simple Motion : Explanation about sample motion creation.

Check our website for more motion samples.
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05
Edited motions are saved as a file. Saved motions files can be batch downloaded 

to the DRC controller (Existing files in the DRC will be deleted). Downloaded files 

are ginve a number according to the order of download which then can be loaded

and used by DR-Visual Logic(Task Editor).

Click

Save Robot Motion

To save the robot motion, File > Save As 

> insert file name and save.

01 Robot Control

With the robot and DR-SIM connected, 

click on “Robot Control” icon.

02 Robot Control Window

Motion information download popup 

opens up. Top section shows the 

directoy of saved motion files. Left 

window shows motion list saved in 

the PC. Files downloaded to the DRC 

will be listed by number on the right 

window.

Download

Click1

Click2

save
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03 Open Saved File Folder

Click on the folder icon at the right side 

of the folder directory to open up the 

folder search popup window. Click to 

select the folder where the motion files 

are saved.

04 Motion List

Left window shows the list of motions in 

the selected folder. Place the cursor on 

the list and click the download icon.

05 Download

Robot motions will be downloaded one 

at a time.

Click2

Click2

Click1

Click1
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06 Controller Motion List

Once all the motions are downloaded, 

motions will be listed from number 0 in 

the controller motion list window on the 

right side.

Numbers can be called up by index 

when programming with DR-Visual Logic 

(Task Editor). This ends the lesson in 

robot motion download.
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Creating Motion06
Creating Motion - Step by Step

There are two different methods of creating motion. One method is to use the 

3D motion window, motion can be created by clicking on robot joints and using 

the motion lines. Another way is to capture the motion from the robot. Following 

lesson will show how to create motion by using both methods.

01 New File

File > Click on ‘New File’.

02 New Motion Window

Previous motion window will disappear 

and new robot 3D motion window will 

open.

Click
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03 First Frame

Insert teh basic posture into the first 

frame. Click on the first frame and then 

click on the key frame insert.

04 New Motion Window

Motion window can be opened up 

separtely and enlarged to conveniently 

edit motion on screen.

Total of three 3D motion windows can 

be opened at same time and placed 

side by side or top and bottom to be 

used for editing.

View > Click on ‘New 3D Motion Window’.

Use the mouse to drag and elarge the 

newly opened 3D popup window.

Click1

Click2

Click

05 Enlarging Robot

Robot in the edit window can be 

enlarged.

Click on an empty space and use the 

mouse wheel to zoome in or out.

To change the angle, press and hold 

the right mouse button and drag. 

To change the robot position, press shift 

+ press and hold right mouse button 

and drag.

Wheel up/Down1

Alt+Drag/Shift+Drag2
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06 Edit Arm Motion

Lifting the arm. Click on the shoulder 

area and yellow motion line will appear. 

Click and drag along the motion line to 

lift the arm.
Click1

Drag2

07 Insert Key Frame

Insert the lifted arm motion into the 

frame. Click on the desired frame and 

then click on ‘key’ icon to insert the 

motion.

08-1 USB to Serial Converter

Start connection to the robot.

USB to Serial conversion cable that 

connects robot to the PC/Notebook 

USB port.

Click2

Click1
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08-2 USB port

Connection to the PCs with Serial Port 

in the back can made using the serial 

cable but connection to notebook 

computers without the serial port

requires USB to Serial converter.

08-3 Connecting to Robot

Connect the RS232c audio jack to the 

robot.

08-4 Robot Port

Looking at top of the DRC controller, you 

will find serial port connecting to the PC, 

head side servo motor port, and power 

port.

Photo shows all three ports connected.

08-5 Robot Connection Button

Menu for making connection to the robot 

is located at top right of DR-SIM window.

Click on ‘Environment Setup’ button to 

configure the COM Port.

Click
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09 Environment Setup

Environment Setup window shows 

DR-SIM version, robot selection, and 

Communications setting.

10 Robot Selection

DR-SIM provides total of 6 different types 

of humanoid robot. Most basic robot is 

the 16 axis humanoid.

Select the type of robot that was 

assembled.

Select Hovis Lite 16 DOF

11 COM Port Selection

“PORT” shows the COM Port numbers 

that can be selected. Select one of the 

ports. If there is no connection, go to 

the hardware properties in windows and 

check the number of the COM port

that can be used.

12 Connecting

Click on the ‘Connect’ icon.

13 Connection

As shown in the left photo, Torque button

becomes active when connection to the 

robot is made. Click “Torque On” button 

to operate the robot and click ‘Play’ 

button to play current motion.

Click

Click

Click

Click1 Click2
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14 Robot Motion for Capture

This lesson will show how to caputre and 

edit motion from the robot.Click “Torque 

Off” button and then manually manipulate 

the robot to make desired motion.

15-1 Capture

Click ‘Capture’ button.

15-2 Show Captured Motion in 
                 3D Window

Captured motion is shown in the 3D 

motion window as soon as capture 

button is clicked.

15-3 Insert Key Frame

Insert captured motion into the desired 

frame. Click on the frame first and then 

click on the key frame.

Click

Click2

Click1
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16-1 Different Motion

Manually make a different motion.

16-2 Capture

Capture.

17 Check Motion

Compare the manually made motion with 

the motion in the 3D motion window.

Click
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18 Capturing

Capture the newly made motion

19 Insert Key Frame

Insert motion in the desired frame.

20 Delay Value

Robot may make a suden movement 

if there is a large motion difference 

between the first and the second 

motion key frame. To prevent such a 

sudden movement, there is a way slow 

down the first motion.

Click  bottom of the frame and drag 

to the right with left mouse button 

pressed. Such an action will show up 

as photo on the left and Delay value 

will be created. 

Click

Click1

Drag2
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21 Screen Play

Play the created motion in the motion 

window.

Click ‘Play’ icon.

22 Play

Progress line shows the motion being 

played progressing on the time frame.

23 Play On Robot

Apply and play the motion on robot. 

Click ‘Play’  button located near top 

right.

24 Robot Motion

Left photo shows the motion created 

in 3D motion window. middle and 

right photos show captured motions.

When played, motions will be played 

consecutively.

Click

Click
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Multimedia Effect 07
Editing and applying face LED effect to robot motion

We will use DR-SIM to apply face LED effect to the robot motion.

Face LED enables robot to simulate emotions during motion. Steps in creating and 

running facial LED effect consists of editing face LED effect according to each type 

of emotion, saving LED effect to PC, downloading to the robot, and applying effect 

from the motion frame to the robot motion.    

01 Face LED edit window

Click Face LED > Select/Edit button to 

open facel LED edit window.

02 Edit face LED according 
         to each type of emotion.

Edit face LED according to each type of 

emotion. In this example, we will edit face 

LED to express happiness.

(1) Click “happy” from the emotion list 

window on the left

(2) Select desired color from the color 

palette window and use mouse click to 

apply to the robot forehead, ears, nose, 

and eyes. (Color applied to eyes only).

(3) Save edited effect. (Save to PC).

(4) Try editing other emotions.
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03 Download face LED effect

Edited face LED effect must be 

downloaded to the robot in order to apply 

the effect to the motion. 

Press download button to download the 

edited/saved LED data to the robot.

※ Prior to downloading, check robot   

power status and robot to PC connection.

※ It takes approximately 10s to download 

complete LED data to the robot.

04 Applying to robot motion

Apply edited LED data to robot motion

(1) Select motion frame to apply LED 

effect.

(2) Click select/edit button from the 

face LED window.

(3) Select effect from the list window 

on the left and then click select button 

below.

(4) Apply LED effect to other motion 

frames.


